Osmicards""

Переход на безопасное соединение TLS 1.2

В Августе 2020 года сервис OSMICards переходит на использование стандарта безопасного соединения TLS 1.2. Дополнительно добавлена поддержка наиболее современного стандарта безопасного соединения TLS 1.3

Поддержка давно устаревших и небезопасных протоколов SSL 2.0, SSL 3.0, TLS 1.0 и TLS 1.1 после перехода будет отключена.

Протокол TLS 1.2 был введен в обращение в 2008 году и поддерживается подавляющим большинством  операционных системам, браузерами, серверами и мобильными устройствами.

Для того, чтобы ваше интеграционные решение продолжало успешно  работать с сервисом OSMICards, вам необходимо:

Если у вас используется 1С на платформе версии ниже чем 8.3.9 с установленным модулем интеграции ОСМИ 1С, то обязательно ознакомьтесь со статьей https://support.osmicards.com/knowledgebase.php?article=48

Эта статья так же полезна для включения поддержки TLS 1.2 на ОС Windows и без установленной 1С.

Если у вас используется серверная платформа Windows Server 2003, Windows Server 2003R2 или Windows Server 2008 то самое время обновить платформу до Windows Server 2008R2 или выше поскольку упомянутые платформы не поддерживают стандарт TLS 1.2

Если у вас интеграционные приложение написано на .Net версии 4.0 или ниже, то необходимо обновить приложение до платформы .Net 4.5 или выше и включить поддержку TLS 1.2 в ОС Windows

Если в интеграционном приложении вы используете библиотеки OpenSSL версии ниже чем 1.0.1 или библиотеки Delphi Indy версии ниже чем 10.6.2 то нужно обновить ваше решение с более современными библиотеками.

 

Метаданные статьи

Идентификатор статьи:
49
Категория:
Дата добавления:
2019-12-22 13:23:29
Просмотры:
1,257
Рейтинг (Голоса):
(178)

Связанные статьи